[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4758: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4759: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
Kerkythea Rendering System • View topic - "Bitmaps are missing" bug? Lost work :(
FAQ  •  Register  •  Login

"Bitmaps are missing" bug? Lost work :(

Moderator: ModeratorGroup

<<

psiho

Posts: 11

Joined: Mon May 12, 2008 9:28 pm

Post Sat May 24, 2008 9:05 pm

"Bitmaps are missing" bug? Lost work :(

<<

sintra

KT-Team
KT-Team

Posts: 1120

Joined: Fri Oct 13, 2006 8:57 am

Location: United Kingdom

Post Sat May 24, 2008 9:16 pm

Attachments
ScreenHunter_01 May. 24 22.14.jpg
Last edited by sintra on Sat May 24, 2008 9:18 pm, edited 1 time in total.
Kind regards

Darren

Sketchup6 & Kerkythea
Dell Precison M90 notebook, Intel Core 2 Duo 2.33 Ghz, 4Gb of Ram, nVidia Quadro FX 2500M

Image


http://www.flickr.com/photos/darrengoodwin/show/
<<

patricks

KT-Team
KT-Team

Posts: 3209

Joined: Mon Nov 14, 2005 2:39 am

Location: Palma de Mallorca / Spain

Post Sat May 24, 2008 9:17 pm

<<

psiho

Posts: 11

Joined: Mon May 12, 2008 9:28 pm

Post Sat May 24, 2008 9:51 pm

Something very strange here. Nope.. it doesn't make any difference if I save with textures.

I tried the same with my real work and it did produce a bunch of files, some in same folder of my scene and some in TX_myscene subfolder. However, same error message.

Also. Even if your workarround worked, I would still consider this behaviour a bug. I want to organize my materials neatly in subfolders and this way KT dumps huge amount of duplicate images into my work folder. But ok, if you ask for it, . it is ok to get it. However... then what is is the value of that regular save method (without textures)? I don't see a value of that file at all if there are no links to images anymore. You cannot render that file, cannot send it to others, nothing.

Normal behaviour in my opinion would be that links to file locations are stored in file when doing regular save. And if you chose saving method "with textures" then move those images and update links in document to local ones.
<<

patricks

KT-Team
KT-Team

Posts: 3209

Joined: Mon Nov 14, 2005 2:39 am

Location: Palma de Mallorca / Spain

Post Sat May 24, 2008 10:00 pm

Hi psiho

could you say on what operation system you are using KT ... windows , linux , Mac ? and another thing ... did you download the last bug fix for windows KT build v.2.0.9 at the bug section of our forum ?

we take notice of your "wish" on how you think texture saving should be made

Greetings Patrick
<<

psiho

Posts: 11

Joined: Mon May 12, 2008 9:28 pm

Post Sat May 24, 2008 10:37 pm

Using Vista... tried running as Admin and as regular user.
Was using 2.0.5 but just downloaded 2.0.9 and run through steps to reproduce - error remains.

Did you try to reproduce steps exactly? Wierd thing is that I have to change all 3 bitmaps mentioned, not just one. I use same bitmap for specular and texture, and another one for diffuse. In such situation problem is 100% times reproducable om my machine. I'll try tommorow on XP and another machine.
<<

Avariant

KT-Team
KT-Team

Posts: 765

Joined: Tue Aug 28, 2007 5:47 pm

Post Sat May 24, 2008 11:10 pm

Hey psiho,

I tried your outline procedure exactly and didn't have any problem.

Here's a possibility: what is the full file path and file names to your images? It's possible there is a foreign language character that is causing problems. Try selecting an image from a very simple location on your machine, like C:\test.jpg for all the channels.

Also, you said one of the images was the 'Texture' channel. Did you mean bump mapping or normal mapping or what? ;)
<<

Fletch

KT-Team
KT-Team

Posts: 8564

Joined: Fri Oct 27, 2006 2:38 am

Location: Milwaukee, WI USA

Post Sat May 24, 2008 11:57 pm

is this possibly related to issue?


<<

Avariant

KT-Team
KT-Team

Posts: 765

Joined: Tue Aug 28, 2007 5:47 pm

Post Sun May 25, 2008 12:37 am

I don't think so, Fletch. He said he tried it first in 2.0.5 and then in 2.0.9, and the problem was in both versions. The issue you linked to seems to be new in 2.0.9.
<<

Pg09

KT-Explorer

Posts: 227

Joined: Thu Mar 27, 2008 3:05 pm

Location: Port of Spain

Post Sun May 25, 2008 3:21 am

Edited: Ok, i just deleted my long story :)

The cliffnotes are that i had the same problem i.e. KT didn't see the textures on my new laptop when i transferred my whole workfolder over without changing anything. It turned out that on my old laptop i stored the textures in a subfolder next to the KT file (to keep the folder clean) but on the new laptop KT needed to to have the textures in the same folder as the KT file...

Also when i first used the save with textures function i thought that the textures are saved into the file but in reality they were just saved into the same folder. It took a while to figure that out :)

As Fred says usually: I hoped that helps... :D
cheers,

Adam
<<

psiho

Posts: 11

Joined: Mon May 12, 2008 9:28 pm

Post Sun May 25, 2008 11:26 am

<<

giannis

Site Admin

Posts: 4627

Joined: Mon Jul 04, 2005 9:59 am

Location: Athens, Greece

Post Sun May 25, 2008 1:43 pm

<<

Avariant

KT-Team
KT-Team

Posts: 765

Joined: Tue Aug 28, 2007 5:47 pm

Post Sun May 25, 2008 4:12 pm

<<

giannis

Site Admin

Posts: 4627

Joined: Mon Jul 04, 2005 9:59 am

Location: Athens, Greece

Post Tue May 27, 2008 6:09 pm

<<

maKe_Studio

Posts: 2

Joined: Mon Sep 22, 2008 10:49 pm

Post Sat Jan 31, 2009 12:52 am

It's great that this problem has been solved internally...

Next

Return to Bug List

Who is online

Users browsing this forum: Google [Bot] and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.