[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4758: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4759: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
Kerkythea Rendering System • View topic - Material Problem
FAQ  •  Register  •  Login

Material Problem

Moderator: ModeratorGroup

<<

Dave R

KT-Warrior

Posts: 144

Joined: Tue Oct 25, 2005 4:04 pm

Post Sun Sep 08, 2013 3:17 pm

Material Problem

I've come up with a problem I haven't seen before. I'd search to see if the solution has been posted but I don't know what search terms to use.

The issue is that some of the materials I've created in SketchUp don't seem to carry over to KT. Here's the image from SU:


And the way they render out in KT.


The walnut and maple materials were made in exactly the same way from PNG images that were created using the same software. Even in the TX folder generated by the exporter, the walnut materials appear as green. What's the fix?

Actually I hadn't thought about it before but the cabinet is kind of cool with the green doors and drawer fronts.
<<

Student

KT-Fellow

Posts: 46

Joined: Tue Oct 01, 2013 7:02 pm

Location: NZ

Post Mon Dec 09, 2013 11:20 am

Re: Material Problem

check the materia is painted/applied on both sides of the sketchup surfaces
<<

Dave R

KT-Warrior

Posts: 144

Joined: Tue Oct 25, 2005 4:04 pm

Post Mon Dec 09, 2013 11:52 am

Re: Material Problem

Huh? I've never had to apply materials to both sides of SketchUp faces before. I didn't apply it to both sides of the faces that use the light-colored wood. I don't believe that will change anything.
<<

Student

KT-Fellow

Posts: 46

Joined: Tue Oct 01, 2013 7:02 pm

Location: NZ

Post Tue Dec 10, 2013 6:02 am

Re: Material Problem

sometimes it does automatically sometimes not-i just remembered seeing it somewhere else (cant remember where though). And it has made the difference in some of my models before. apparently kerky uses the wrong side of the 'face'
I just realised too that I cant see the images posted-that may make it all make more sense
<<

Fletch

KT-Team
KT-Team

Posts: 8564

Joined: Fri Oct 27, 2006 2:38 am

Location: Milwaukee, WI USA

Post Tue Dec 10, 2013 10:08 am

Re: Material Problem

Kerkythea only renders the "Front" face of your model.
(The "front" face in any 3D program is the face with the "normal" in the "positive" direction.)
In ACAD, it's nearly impossible to tell which side is the front face, but in SketchUp, it's the white side. The back side is blue.
In SketchUp you can go to Monochrome View using the view styles tool pallette. This will temporarily hide the materials and show which are front and which are back faces.

If you intend to render something, be sure your front faces are painted, and avoid painting groups or components with a material.


<<

Dave R

KT-Warrior

Posts: 144

Joined: Tue Oct 25, 2005 4:04 pm

Post Tue Dec 10, 2013 10:17 am

Re: Material Problem

thanks for the comments, Fletch. You probably know that two of the things I am AR about are no exposed back faces and painting faces not components. I can assure you that the model is done correctly. This has happened with just a few of my material images so I have to assume it's something about those images. The images display properly in SU and in several different image editors. Only KT makes them bright green.
<<

massimo

KT-Wizard

Posts: 606

Joined: Sun Apr 05, 2009 3:58 pm

Location: Italy

Post Tue Dec 10, 2013 5:20 pm

Re: Material Problem

Dave I think that the cause is that you're using PNG 16-bits images. If so convert them to 8-bits. It should work.
<<

Dave R

KT-Warrior

Posts: 144

Joined: Tue Oct 25, 2005 4:04 pm

Post Tue Dec 10, 2013 5:45 pm

Re: Material Problem

Thanks Massimo.

I tried that but here's what the Materials look like in KT. No change. :(
kt mats.png
<<

massimo

KT-Wizard

Posts: 606

Joined: Sun Apr 05, 2009 3:58 pm

Location: Italy

Post Tue Dec 10, 2013 6:02 pm

Re: Material Problem

That's weird. I can replicate that green with a 16-bits PNG but not with a 8-bits one. Could you post a small sample of a problematic texture?
<<

nick chun

KT-Fellow

Posts: 39

Joined: Sat Feb 05, 2011 9:07 pm

Post Thu Dec 12, 2013 6:22 pm

Re: Material Problem

I think you will find it gives similar problem if rendered in Twilight as well
<<

Dave R

KT-Warrior

Posts: 144

Joined: Tue Oct 25, 2005 4:04 pm

Post Thu Dec 12, 2013 6:28 pm

Re: Material Problem

Massimo sorted it out. The PNG was saved as Indexed Color mode instead of RGB. I'm not sure how that happened. the image editor i use doesn't seem to have any way to identify that nor control that setting. I've got PhotoShop on another computer so I'll put the materials on that one and make the change. Then I should have some lovely walnut materials for rendering.

Thanks Massimo and to everyone else.

Return to Materials

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.