[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4758: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4759: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
Kerkythea Rendering System • View topic - weird rendering problem
FAQ  •  Register  •  Login

weird rendering problem

Moderator: ModeratorGroup

<<

Takkegek

KT-Fellow

Posts: 37

Joined: Wed Mar 13, 2013 8:40 pm

Post Wed Jun 19, 2013 7:10 am

weird rendering problem

Hello,

I am still pretty new on this forum. I was rendering a scene and there appeared a fault in my render. I know that lights may not interfere with faces so this is normally not the problem. Can anyone tell me what could be wrong here?
Could it be that the models ( seats and cups ) have to much triangles ( faces ) ?

Really hope someone could help me!
test 107 probleem 2.jpg

Takkegek
<<

notareal

KT-Team
KT-Team

Posts: 4211

Joined: Fri Oct 27, 2006 7:27 am

Location: Finland

Post Wed Jun 19, 2013 7:14 pm

Re: weird rendering problem

Is scene in correct scale (one small cell in KT ground grid is 1x1 meters)? Scene also needs to be located near origin. Looking the image I do get a impression that there also some modelling issue, faceted table... Can you tell more about the process, modelling app and so? Is scene created by a some KT exporter or is it some imported .obj or .3ds?
Thea Render and Kerkythea Rendering System, by Solid Iris Technologies
<<

Takkegek

KT-Fellow

Posts: 37

Joined: Wed Mar 13, 2013 8:40 pm

Post Thu Jun 20, 2013 7:21 am

Re: weird rendering problem

Thanks for the quick reply!

The model is made in sketchup with 3ds-files imported to the sketchup-file ( the table/seats/coffee cup ). These objects have 'lots' of triangles. Is that a wrong way to import these files? ( is faceted table a problem? )
After this I exported it from sketchup in kerkythea ( with KT-exporter )
I think the scale is correct. I always draw in millimeters in sketchup but the export is right I guess.
What would be a problem is that the model is not very near to the origin. I will test that with model moved.
Further I rendered 20.MLT BPT. KT rendered a night ( 8 hours) for this picture.

Thanks!
Takkegek
<<

notareal

KT-Team
KT-Team

Posts: 4211

Joined: Fri Oct 27, 2006 7:27 am

Location: Finland

Post Thu Jun 20, 2013 8:09 pm

Re: weird rendering problem

Polygon count is usually not a issue. Generally you get better looking result with high poly model. Perhaps it's just some bad model. I think I only seems something similar when scene is really out of scale and models are far from origin (not just few meters, but few hundreds or even kilometers). Perhaps you could try to get model as .obj and import it to SU.
Thea Render and Kerkythea Rendering System, by Solid Iris Technologies
<<

Takkegek

KT-Fellow

Posts: 37

Joined: Wed Mar 13, 2013 8:40 pm

Post Fri Jun 21, 2013 4:44 pm

Re: weird rendering problem

Yes the model is moved away from the origin. Possible a couple of hundred meters. But the model is made close to the origin in sketchup. Than exported to KT. But after this scene opened in KT, then it's far from the origin in KT. Why does it differs between sketchup and KT? Is there something to do about it? -> problem is that whole the model moving ( incl. lights, cameras,.. ) in KT makes KT crash.. So the problem would be solved if the origin would be the same in sketchup and KT. Is this possible in a way?

I show you also these pictures to give you an idea of how big the model is outside ( 3D-trees with 3D leafs )
test 106 gimp .jpg

test 105 gimp2 .jpg

test 91 gimp.jpg

Thanks a lot!
Takkegek ( becoming KT-addict )
<<

notareal

KT-Team
KT-Team

Posts: 4211

Joined: Fri Oct 27, 2006 7:27 am

Location: Finland

Post Sat Jun 22, 2013 7:13 pm

Re: weird rendering problem

Right click at the top of the scene tree (scene name) > Transform > Move to Origin. That will fix scene location if it's off for some reason. You got a interesting model...
Thea Render and Kerkythea Rendering System, by Solid Iris Technologies
<<

Takkegek

KT-Fellow

Posts: 37

Joined: Wed Mar 13, 2013 8:40 pm

Post Sat Jun 22, 2013 10:26 pm

Re: weird rendering problem

okay very usefull information about the origin-move, thanks a lot! I will try it out.
Also about the weird rendering problem, I discovered that while exporting a model from sketchup to KT the triangular structure of a model changes. This is only when the model is fully smoothed in sketchup. When not smoothed in sketchup than the triangular structure stays the same. So you were right that the model was bad ( because it became bad while exporting ).
Btw, the model was a project I made in my student-hood, ideal to learn KT ;)

Return to Bug List

Who is online

Users browsing this forum: No registered users and 0 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.